Description
The killer Matengss got a new mission to assassinate an evil cat. Matengss needs to be well prepared to win the battle. Now, there are several weapons and Matengss can pick any of them. Each weapon has an ability value. The power of Matengss is sum of the weapons' ability values which he took away. We will tell you the ability value of each weapon. Please calculate the max power that Matengss can get.
Input
The first line contains an integer T ( T < 20) indicating the number of test cases.
Each test case begins with a integer n(n<=1000), means there are n weapons that matengss can choose. The next line contains the values of those weapons ai(|ai|<1000) separated by the space.
Output
Print the max power the matengss can achieve in a single line.
Sample Input
2
3
1 2 3
5
0 0 1 0 4
Sample Output
6
5
我的代码
#include "stdio.h"
int main()
{
int T,n,i,j,ai,b,h,sum=0;
while( scanf("%d",&T)!=EOF)
{
for( i=1; i<=T; i++ )//控制多少数据
{
scanf("%d",&n);//魅族数据个数
{
for( b=1;b<=n; b++)
{
scanf("%d",&ai);
{
sum+=ai;
}
}
//printf("%d\n",sum);
// sum=0;
}
printf("%d\n",sum);
sum=0;
}
// printf("%d\n",sum);
// sum=0;
}
return 0;
}
The next line contains the values of those weapons ai(|ai|<1000) separated by the space.
武器的攻击力有可能是负数,这个时候不选。