素数判定

Problem Description
对于表达式n^2+n+41,当n在(x,y)范围内取整数值时(包括x,y)(-39<=x<y<=50),判定该表达式的值是否都为素数。

Input
输入数据有多组,每组占一行,由两个整数x,y组成,当x=0,y=0时,表示输入结束,该行不做处理。

Output
对于每个给定范围内的取值,如果表达式的值都为素数,则输出"OK",否则请输出“Sorry”,每组输出占一行。

Sample Input
0 1
0 0

Sample Output
OK

C语言版本
Anywise, If you have any issue, please let me know. Thanks.

#include "stdio.h"
#include "math.h"
#include "string.h"

int Decision_Prime(int num)//**There is deciding whether the num is prime. The Number "0" was representative prime and "1" was no prime.**
{
int i = 2;

    while(i < num)
    {
            if(num % i == 0)
            {
                    break;
            }
            i++;
    }
    if(num == i)
    {
            return 0;
    }
    else
    {
        return1;
    }

}

int main()
{
int x,y,n;
int flag = 0;

//**input the number (x,y)**
printf("Please input the X-value:");
scanf("%d",&x);
printf("Please input the Y-value:");
scanf("%d",&y);

n = x+1;

while(n < y)
{
    flag = Decision_Prime(n);
    if(flag != 0)
    {
        break;
    }
    n++;
}
if(n==y)
{
    printf("OK\n");
}
else
{
    printf("Sorry\n");
}
return 0;

}

建议你看看《算法之美》,用双层递归